プロジェクト

全般

プロフィール

整備 #4133

cmake_minimum_requiredを3.0.2とする

n.kawauchi4ヶ月前に追加. 約2ヶ月前に更新.

ステータス:
終了
優先度:
通常
担当者:
対象バージョン:
開始日:
2017/07/04
期日:
進捗率:

100%


説明

  • OpenRTP1.2.0版からRTCBuilderが生成するファイルの文字コードがUTF-8 BOM付きとなった
  • これに伴い、CMakeLists.txtなどCMake関連のファイルもUTF-8 BOM付きとなっている
  • CMakeの2.8はUTF-8 BOM付きが扱えず、CMakeLists.txtの1行目でエラーとなる
  • このため、cmake_minimum_requiredの設定を変更する
    cmake_minimum_required(VERSION 2.8 FATAL_ERROR)
         ↓
    cmake_minimum_required(VERSION 3.0.2)
    

関係しているリビジョン

リビジョン 746 (差分)
ga3ヶ月前に追加

Modified CMakeLists.txt #4133

リビジョン 747 (差分)
ga3ヶ月前に追加

Modified CMakeLists.txt #4133

リビジョン 748 (差分)
ga3ヶ月前に追加

Modified CMakeLists.txt #4133

リビジョン 757 (差分)
ga3ヶ月前に追加

Modified CMakeLists.txt #4133

リビジョン 758 (差分)
ga3ヶ月前に追加

Modified CMakeLists.txt #4133

リビジョン 759 (差分)
ga3ヶ月前に追加

Modified character encoding #4133

履歴

#1 ga3ヶ月前に更新

  • ステータス新規 から 解決 に変更
  • 進捗率0 から 100 に変更

修正させて頂きました r746,747,748

#2 n.kawauchi3ヶ月前に更新

  • ステータス解決 から フィードバック に変更
  • 進捗率100 から 90 に変更

修正して頂きましたが2.8へ戻してください。
Ubuntu14.04のデフォルトのバージョンが2.8.12であること、古いraspbian環境も考慮すると、
3.0.2とするのは時期尚早という判断になりました。

ただし、この機会にFATAL_ERRORオプションは外して下さい。CMake2.6以降では無視されるとあります。
cmake_minimum_required(VERSION 2.8) でよいと考えています。
https://cmake.org/cmake/help/v3.0/command/cmake_minimum_required.html

2.8にしますと、cmakeのファイルがUTF-8 BOM付きには対応しておりません。UTF-8 BOMなしへの変更をお願いします。
修正対象は、CMakeLists.txt, *.cmake, *.cmake.in ファイルになると思います。

また、3.0.2未満では対応していない構文に対しての修正をお願いします。
Pythonの一番トップのCMakeLists.txtに対して。

# start menu
set_property(INSTALL "${INSTALL_PREFIX}/${PROJECT_NAME}.py" 
    PROPERTY CPACK_START_MENU_SHORTCUTS "${PROJECT_NAME}.py")

 ↓以下のように修正

if(WIN32)
    # start menu
    set_property(INSTALL "${INSTALL_PREFIX}/${PROJECT_NAME}.py" 
        PROPERTY CPACK_START_MENU_SHORTCUTS "${PROJECT_NAME}.py")
endif()

C++ではこれと同じ構文はありません。同じ機能はあるのですが、他の命令を使っています。
以上、よろしくお願いいたします。

#3 ga3ヶ月前に更新

  • ステータスフィードバック から 解決 に変更
  • 進捗率90 から 100 に変更

修正させて頂きました r757,758

#4 n.kawauchi3ヶ月前に更新

  • ステータス解決 から フィードバック に変更
  • 進捗率100 から 90 に変更

確認したところ、cmake/utils.cmake の文字コード修正が漏れています。
このため、cmakeバージョンが2.8.12.2のUbuntu14.04でcmakeが通りませんでした。
対応、よろしくお願いいたします。

#5 ga3ヶ月前に更新

  • ステータスフィードバック から 解決 に変更
  • 進捗率90 から 100 に変更

たいへん失礼いたしました.再度,修正させて頂きました.r759

#6 n.kawauchi2ヶ月前に更新

確認が遅くなりました。OKです。ありがとうございました。

#7 n-ando約2ヶ月前に更新

  • ステータス解決 から 終了 に変更

他の形式にエクスポート: Atom PDF